Hyperion Foundation - Server Maintenance – Incident details

All systems operational

Server Maintenance

Resolved
Operational
Started over 1 year agoLasted 5 minutes

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    We're sorry to say this but we need to do something on Shaii server.